Scheduled for August 31, 2026 at 2:00 PM – 2:30 PMUTC
Affects
Login service
Under maintenance from 2:00 PM to 2:30 PM
Updates
Completed
August 31, 2026 at 2:30 PMUTC
Completed
August 31, 2026 at 2:30 PMUTC
Maintenance has completed successfully
In progress
August 31, 2026 at 2:00 PMUTC
In progress
August 31, 2026 at 2:00 PMUTC
Maintenance is now in progress
Planned
August 31, 2026 at 12:28 PMUTC
Planned
August 31, 2026 at 12:28 PMUTC
We are restarting our authentication service to apply a fix. During this window you may experience brief login interruptions. Thank you for your patience.